TextPad 検索  |  コンタクト  |  ホーム   
サポート
フィードバック  |  FAQ  |  ヒント  |  リリースノート  |  メーリングリスト  |  フォーラム

 

最終更新日: 10th October, 2001

これらのヒントは、多くがユーザーからいただいたものです。ここに掲載ものがありましたら support@textpad.comまでお知らせください。


ツールメニューで SQL バッチファイルを MySQLへ送るコマンド

TextPadから MySQL を使う。

mysql を .BAT から実行

セットアップ:

1. 下の一行を含む バッチファイル (mysql.bat) を作ります:
     mysql -vvv < %1
			自分の好きなPATHにおきます - 私は C:\ を使っています。
		
2. Textpadで:設定:環境設定:ツール:追加...
			コマンド: c:\mysql.bat
			引数: $File
			開始フォルダー: $FileDir
			出力の取り込みをチェック

3. ご自分のsqlファイルを書いてください、最初の行にはデータベースの名前を含みます。
(In another_trial.sql)

			use test;

			create table noch_try(
			jnum int,
			jwrd varchar(50)
			);

			show tables;
4. ツールを実行。

5. 結果 :

			--------------
			create table noch_try(
			jnum int,
			jwrd varchar(50)
			)
			--------------

			Query OK, 0 rows affected (0.00 sec)

			--------------
			show tables
			--------------

			+-----------------+
			| Tables_in_test  |
			+-----------------+
			| event           |
			| imptest         |
			| noch_try        |
			| pet             |
			+-----------------+
			4 rows in set (0.00 sec)

		
もちろん、ドロップテーブルなどをCREATEコマンドの前に必要ならば入れなければなりません。

TextPadから MySQL テーブルへ入力
使用するコマンド:
mysqlimport [options] database textfile1

[mySQL Manual Section 14.6 にオプションがあります]

MySQL インポート用設定:設定:環境設定:ツール:追加...

				コマンド: C:\mysql\bin\mysqlimport.exe
				引数: --local --fields-terminated-by=^ -v database $File
				開始フォルダー: $FileDir
				引数入力の要求チェック - データベースを毎回入力したいとき。
		
基本の名前は書き出したいテーブルと同じ名前にしてください :

セッション例 ;
1. mysqlでテスト用テーブルを作成 :

				mysql> use test; -- これがこれから使おうとするデータベース
				Database changed
				mysql> create table try_it(num int, wrd varchar(50));
				Query OK, 0 rows affected (0.00 sec) -- テーブルができました。

2. Textpadでデータを作成、 (UNIX フォーマットで)テーブルと同じ名前で保存。 ( try_it.txtの中で)
				1^This is the first one^
				2^A second Entry^
				3^My separator is seldom used in text^
				4^Note that separator is used also at the end^
				5^Because it marks cell termination.^
				6^Far handier for inputting data to tables^
				7^Also, save in UNIX format for correct^
				8^Line endings (Record Termination)^
				9^Pretty useful.^

3. Textpadからツールを実行 : (引数の入力にtestを入力).
				Connecting to localhost
				Selecting database test
				Loading data from LOCAL file: C:/Windows/DESKTOP/try_it.txt into try_it
				test.try_it: Records: 9  Deleted: 0  Skipped: 0  Warnings: 9
				Disconnecting from localhost
				Process completed successfully

4. mysqlにテーブルを選択させる :
        mysql> select * from try_it;
				+------+======================================-------+
				| num  | wrd                                         |
				+------+======================================-------+
				|    1 | This is the first one                       |
				|    2 | A second Entry                              |
				|    3 | My separator is seldom used in text         |
				|    4 | Note that separator is used also at the end |
				|    5 | Because it marks cell termination.          |
				|    6 | Far handier for inputting data to tables    |
				|    7 | Also, save in UNIX format for correct       |
				|    8 | Line endings (Record Termination)           |
				|    9 | Pretty useful.                              |
				+------+======================================-------+
				9 rows in set (0.00 sec)

		

このヒントの提供は: John Montgomery


CtagsをTextPadのツールに構成するには

Ctagsは、インデックステーブルを作成してTextPadの実行結果に表示することができます。Ctagsはここからダウンロードします:
http://darren.hiebert.com/ctags/

TextPadの環境設定で、下記のDOSツールセットアップを行います:

引数: ctags -x -R | grep "^$Sel\>"

正規表現: ^[[:alnum:]_]+ +[a-z ]+\([0-9]+\) +\([^ ]+\)

ファイル名 = 2
行 = 1

開始フォルダーを検索したいソースコードのあるフォルダーツリーのトップにおきます。

メモ: 動作させるにはctagsとgrepにパスが設定されていることが必要です。cygwinツールセットを導入したときのgrepを使います。 ダウンロードはhttp://sources.redhat.com/cygwin/ (MKSツール同様に使えます) ctagsの特徴は C, C++, PERL, Java, Fortran,そのほかも同様にサポートしています。

使用するには、キーワードを選択してツールを起動し、実行結果のウインドウで結果の行をダブルクリックするだけです。

このヒントの提供は: David Vanden Heuvel, Software Designer, Zucotto Systems, Inc.


Ctagsを使って識別子の定義位置にジャンプさせるには。

1. "Exuberant Ctags"をダウンロードします。フリーで http://ctags.sourceforge.net/からダウンロードできます。
2. Ctagsファイルを作成します。 -n オプションをつけて行番号を出力してください。
3. e-mailに添付したC++ プログラムをコンパイルします. C++コンパイラーが必要であれば、 DJGPP がフリーで: http://www.delorie.com/djgpp/
4. ツールを登録します:
				コマンド:  < C++ プログラムの名前>
				引数: <ctags ファイル名> $SelWord
				開始フォルダー: $FileDir
				オプション: 出力の取り込み、終了まで出力しないをチェック
				正規表現: ^.*, (.*), ([0-9]+)
				ファイル: 1
				行: 2
		
5. あとは、識別子のうえにキャレットを移動しツールを起動するだけです。 出力された結果をダブルクリックすれば、希望の行き先にジャンプします。

メモ:
1. この方法はctagsとコードが同じディレクトリーにあることを想定しています。そうでない場合変更が必要です。
2. POSIX 準拠の正規表現を使用しています。そうでない場合括弧の前にバックスラッシュをふかしてください。

ctagsファイルを作成するC++ :

		// C++ program to dump ever occurrance of a given tag in a tag file
		// Usage: <prog> <tag file> <tag>

		#include <string>
		#include <iostream>
		#include <fstream>
		#include <cstring>
		#include <cctype>

		using namespace std;

		int main(int argc, char* argv[])
		{
			// check for correct number of arguments
			if (argc != 3)
			{
				// strip path from progam name
				const char* prg = argv[0];
				const char* const fslash = strrchr(prg, '/');
				const char* const bslash = strrchr(prg, '\\');
				if (fslash && bslash)
					prg = fslash > bslash ? fslash + 1 : bslash + 1;
				else if (fslash)
					prg = fslash + 1;
				else if (bslash)
					prg = bslash + 1;

				cerr << "Usage: " << prg << " <tag file> <tag>" << endl;
				return -1;
			}

			ifstream f(argv[1]);
			if (!f)
			{
				cerr << "Failed to open file." << endl;
				return -1;
			}

			string tag(argv[2]), ftag, file, type, tmp;
			unsigned line;
			while (f && !f.eof())
			{
				f >> ftag;

				if (ftag == tag)
				{
					f >> file >> line;

					getline(f, tmp); // get remainer of line

					// look for type infomation
					type = "";
					int pos = tmp.find(";\"");
					if (pos >= 0)
					{
						// skip whitespace
						pos += 2;
						while (isspace(tmp[pos]))
							++pos;

						type = string(", ") + tmp.substr(pos);
					}

					cout << ftag << ", " << file << ", " << line << type << endl;
				}
				else
					getline(f, tmp); // disgard line
			}

			return 0;
		}
		

このヒントの提供者: Rich Herrick, Lockheed-Martin Federal Systems, Owego, NY


TextPad をVBScriptのエディターとして使う。

新しいツールをセットして TextPadから VBScript (*.vbs) ファイルを実行することができます。

1. "設定"メニューから"環境設定"を選択
2. ツールマネージャーを選択.....

"Explorer.exe" を $File と$FileDirパラメーターを設定して追加。

又は

Windows NT/2000ユーザーは "cmd" を $File と $FileDirパラメーターとともに追加 users. Win 9x ユーザーは、"command"を使います。

Microsoft Windows Scripting Host (WSH) をインストールしていればTextPadからVBScriptを起動することができます。

このヒントは: Peter Gomis, Senior Developer, Skandia AFS IT - Global Systems Engineering Services, Shelton, CT


変更のコミットを CVSのレポジトリーにコミットするためのユーザーツール定義。

全ての例はDOSクライアントがインストールされて、あなたのモジュールがチェックアウトされている必要があります。

CVS ログイン

		コマンド: drive:\path\to\cvs\cvs.exe
		引数: -z9 -d :pserver:user@host:/path/to/cvs/repository login
		開始フォルダー: $FileDir
		

このコマンドの出力を取り込まないでください。これはパスワード入力が必要なコマンドです。

CVS アップデート

		コマンド: drive:\path\to\cvs\cvs.exe
		引数: -z9 update
		開始フォルダー: $FileDir
		

CVS コミットファイル

		コマンド: drive:\path\to\cvs\cvs.exe
		引数: -z9 commit -m "" $FileName
		開始フォルダー: $FileDir
		

引数の入力を促す必要があります。ログメッセージをダブルクオーテーションの間に記述してお使いください。

このヒントの提供は:: Dave Weiner - Chief Technology Officer, WebMasters, Inc. - www.webmast.com


自動インストールプロセス

下記の手順に従って、ユーザーの入力を必要としない標準インストール手順を構築することができます。

最初にセットアップで選択するファイルを記録します:

  1. 自己解凍ファイル(e.g. TXPENG41.EXE)をWinZipなどのZIPプログラムなどで開きます 。
  2. 全てのファイルをサブフォルダーの構成を保ったままサーバーに解凍します。
  3. スタートメニューからファイル名を指定して実行を選び、DISK1サブフォルダーから下記のように実行します:
    SETUP.EXE -r
  4. オプションを選択しながら通常のインストールを実行してください。
  5. この作業は WindowsフォルダーのSETUP.ISSに記録されます。 SETUP.ISS を DISK1 に移動します。

次にTextPadを希望する設定にします:

  1. TEXTPAD.EXEを実行。
  2. ヘルプメニューの "ライセンスの登録"を選択。
  3. ライセンスコードを入力して OKをクリック。
  4. 設定メニューから環境設定を選択。
  5. 設定したい項目を変更してOkをクリック。
  6. TextPadを終了。

ここで、TextPadの設定をレジストリーから抜き出します:

  1. スタートのファイル名を指定して実行から REGEDIT.EXEを実行
  2. エクスポートコマンドを使用して下記のレジストリーを HKCU.REGファイルに書き出します:
    HKEY_CURRENT_USER\Software\Helios\TextPad 4
  3. 下記のレジストリーも HKLM.REGへ書き出します:
    HKEY_LOCAL_MACHINE\Software\Helios\TextPad 4
  4. TextPad を使って HKCU.REG とHKLM.REGを開きます。
  5. 新規ドキュメントを作成してHKLM.REG の中身を全てコピーします。
  6. 最初の行("REGEDIT4")を除いてHKCU.REG の全てを追加します。
  7. "TEXTPAD.REG"としてDISK2 サブフォルダーに保存します。

最後に DISK1サブフォルダーのセットアップをスタートメニューのファイル名を指定して実行から選び、TextPad をそれぞれのワークステーションに導入します。:

SETUP.EXE -s


Javaプログラムを実行した後自動的にDOSウインドウを閉じるためのヒント。

Windows98上の Textpad Version 4.1に適用できます。
インストール直後では "ツール | Java アプリケーションの実行"メニューオプションは、Javaアプリケーションを実行後MS-DOSウインドウを閉じません。

ツールメニューにこれをさせるように下記のステップを実行します:

  1. Textpad メニュー "設定 | 環境設定"を選択。
  2. 環境設定ダイアログで左側の"ツールマネージャー"を選択します。
  3. "追加"ボタンをクリック、"プログラム"を選択。
  4. "ファイル名" に c:\windows\command.com を入力してエンターキーを押します。
  5. "Command" をゆっくりダブルクリックして 'Quick Run Java アプリケーション' に変更
  6. 'Ok'をクリック。
  7. Textpad メニュー "設定 | 環境設定"を選択。
  8. 環境設定ダイアログで左側の"ツールマネージャー"を選択します。
  9. 'Quick Run Java アプリケーション'をクリック。
  10. 引数に /C java.exe $BaseName と入力
  11. 出力の取り込みのチェックをはずします
  12. 'Ok'をクリック。

ツールオプションからJavaProgramを実行しようとしたとき、Javaプログラムを終了した時点でMSDOSも終了されます。ただしMSDOSに出力された結果も失われます。もし出力を取り込みたいときは、上のステップの一部を:

(alternate step)
11. 出力の取り込みのチェック、終了するまで出力をしないをチェック。

このヒントの提供は:: Jim Burton


MS Visual Sourcesafe 5と使う:

To check the active file in and out of Visual SourceSafeのアクティブファイル inとoutをチェックするには、 SS.EXE を実行するメニューを TextPadに追加します。最初に下記の行を SS.INI に追加します。(あなたのユーザー名の下の \VSS\USERS フォルダーにあります):
			Comment_Editor_Prompt = Yes
			Comment_Editor = notepad.exe
		
コマンドエディターとしてTextPadを使用しないでください、 SS は、コマンド終了まで実行を終了しません。

DOS プロンプトで実行するためには

			C:\VSS\win32\ss.exe checkin file-name
			C:\VSS\win32\ss.exe checkout file-name
		
等価のコマンドをTextPadツールメニューに下記のように追加します:
  1. 設定メニューから環境設定を選択。
  2. 環境設定ダイアログで"ツールマネージャー" を選択。
  3. 追加をクリックしてプログラムを選択。
  4. SS.EXE を探して開いてください。
  5. 適用をクリック
  6. ツールマネージャーの "+"をクリック、 "SS"を選択。
  7. メニューの名前を Check Inに変更。
  8. 引数をcheckin $FileNameに設定。
  9. 開始フォルダーを $FileDirに設定。
  10. チェックボックスのチェックを、出力の取り込み(オプション)を除いて全てはずします。
  11. 適用をクリック
checkout コマンドについて繰り返します。


WS_FTPを用いてドキュメントの出版(アップロード):

アクティブドキュメントを WS_FTPを用いてTextPadからWebサイトにアップロードするには、ツールメニューに下記の設定をします:

		コマンド: C:\Program Files\WS_FTP\WS_FTP95.EXE
		引数: -p My-Profile-Name -s local:$FileName
			  -d My-Profile-Name:/www/htdocs/$FileName
		開始フォルダー: $FileDir

		
これをうまく動作させるにはかなり手間がかかります、引数に入力する文字は上記を守ってください、かつ実際は一行です。チェックボックスは全てはずしてください。My-Profile-Nameをあなたが構成したWS_FTPのプロファイル名に変更してください。ただしプロファイルにはスペースがあってはなりません。"/www/htdocs" をあなたのサーバーのパスに変更してください。"-s"のあとには"$FileName"がアクティブドキュメント名を展開してソースファイル名が続きます。"-d" のあとにはWS-FTPのシンタックスに基づいた転送先ファイル名になります。

このヒントの提供は:: Christopher Locke, Entropy Gradient Reversals, All Noise - All the Time, http://www.rageboy.com/

(David J. Evans 追加: "これを動作させるのにリモートパスの最初の/をとるだけで済みました...おそらくパスはホームディレクトリーからの相対パスで /は不要です。WS_FTPからのエラーメッセージは、少しも役に立ちません!")


WS_FTPを用いてドキュメントの出版(アップロード)ほかのセッティング:

Christopher Locke のTextPadで WS_FTPを使う方法を試してみましたが、彼の方法はうまくいかなかったので設定を変えてみました:
		コマンド:		E:\Program Files\WS_FTP\WS_FTP95.exe
		引数:	-p My-Profile-Name -s Local:$File -d
		My-Profile-Name:	$UNIXPath/$FileName
		開始フォルダー: 	$FileDir
		
Christopherの設定と私のとでは二箇所違いがあります:
1. -s Localでは $File を $FileNameの代わりに使いました。
2. $UNIXPath をunixパスのハードコディングの代わりに使いました。というのも私はunixパスとローカルマシンのパスストラクチャーをミラーリングしているからです。それで$Pathから取得する $UNIXPathは、 unix serverのパスと一致するわけです。

このヒントの提供は:: Feng Wu feng@systechusa.com, Systech Solutions Inc., Glendale, CA, USA.


@-Files:

"@-files"を使用しているとき、 "@-file" 自身の名前をリストに加えるとファイルの追加や削除が簡単にできます。
提供は Ron "Quinn" Straight


Print All:

TextPadは全てを印刷コマンドを持っていますが、メニューにはありません。これを使いたい時にはショートカットにアサインします。:
  1. 設定メニューから環境設定を選択
  2. キーボードショートカットをダイアログから選択
  3. 分類リストから Fileを選択
  4. 操作リストから FilePrintAllを選択
  5. ショートカットキーをタイプ
  6. 割り当てをクリック
  7. 閉じるをクリック


Webページの参照:

"相対URLアドレス"を用いて、ハードディスク上のデータとミラーリングしながらWebサイトを構築しようとしたとき、ファイル名は単にファイル名でwebアドレスではないので、下記の方法で使い易くなります。:
		メニュー:   webページの参照
		コマンド:     C:\Program Files\Internet Explorer\Iexplore.exe
		引数:  http://www.MyWebSite.com/$FileName
		
ローカルにあるページを編集しているとき、このコマンドを実行するとwebサイトから見ているように表示します。

このヒントの提供は:: Christopher Locke, Entropy Gradient Reversals, All Noise - All the Time, http://www.rageboy.com/


検索 & 置換; META NAME エレメントの変換

時折 META NAME の書式を変える必要があります。次の例ではヘッダー情報を Microsoft Knowledge Base article から取得して XMLに変換します。変換は完璧ではありませんが、よいスタートを切れるでしょう。何行にも折り返した行を修正してください。正規表現は折り返した行を変換できません。

検索:
^[^"]+"\([^"]*\)"[^"]*"\([^"]*\)"*.*
置換:
<\1>\2</\1><BR>

変更前:

<TITLE>Q10022 - OFF97: EPS File Is Not Printed or Is Printed Incorrectly Under Windows NT</TITLE>
<META HTTP-EQUIV="CONTENT-Type" CONTENT="text/html; charset=iso-8859-1" />
<META HTTP-EQUIV="PICS-Label" CONTENT="(PICS-1.1 "http://www.rsac.org/ratingsv01.html" l gen true comment "RSACi North America Server" by "Inet@microsoft.com" for "http://support.microsoft.com" on "1998.02.17T12:28-0800" r (n 0 s 0 v 0 l 0))" />
<META NAME="ms.locale" CONTENT="EN-US" />
<META NAME="Category" CONTENT="Support; KB Article" />
<META NAME="Premium" CONTENT="Support" />
<META NAME="KBArea" CONTENT="Support; KB; word97" />
<META NAME="KBID" CONTENT="Q10022" />
<META NAME="KBTitle" CONTENT="OFF97: EPS File Is Not Printed or Is Printed Incorrectly Under Windows NT" />
<META NAME="Description" CONTENT="When you print an Encapsulated PostScript (EPS) file, the file may fail to print or may be printed incorrectly." />
<META NAME="Product" CONTENT="word97" />
<META NAME="KBCreate" CONTENT="April 6, 1984" />
<META NAME="KBModify" CONTENT="April 28, 1999" />
<META NAME="EditDate" CONTENT="January 22, 1999" />
<META NAME="Question" CONTENT="" />
<META NAME="Versions" CONTENT="WINDOWS:97; winnt:4.0" />
<META NAME="Component" CONTENT="" />
<META NAME="Technology" CONTENT="" />
<META NAME="Links" CONTENT="" />
<META NAME="Keywords" CONTENT="kbprint offwin offprint" />
<META NAME="Platform" CONTENT="WINDOWS winnt" />
<META NAME="Hardware" CONTENT="" />
<META NAME="SolutionType" CONTENT="kbfix" />
<META NAME="IssueType" CONTENT="kbbug" />
<META NAME="BoilerPlate" CONTENT="" />
<META NAME="ProducedView" CONTENT="" />
<META NAME="QUERYWORDS" CONTENT="EPS">
<META NAME="QUERYWORDS" CONTENT="filter">
<META NAME="QUERYWORDS" CONTENT="print">
<META NAME="QUERYWORDS" CONTENT="garbled">
<META NAME="QUERYWORDS" CONTENT="does">
<META NAME="QUERYWORDS" CONTENT="not">
<META NAME="QUERYWORDS" CONTENT="is">
<META NAME="QUERYWORDS" CONTENT="printed">

変更後:

<TITLE>Q10022 - OFF97: EPS File Is Not Printed or Is Printed Incorrectly Under Windows NT</TITLE>
<CONTENT-Type>text/html; charset=iso-8859-1</CONTENT-Type>
<PICS-Label>(PICS-1.1 "http://www.rsac.org/ratingsv01.html" l gen true comment "RSACi North America Server" by "Inet@microsoft.com" for "http://support.microsoft.com" on "1998.02.17T12:28-0800" r (n 0 s 0 v 0 l 0))</PICS-Label>
<ms.locale>EN-US</ms.locale>
<Category>Support; KB Article</Category>
<Premium>Support</Premium>
<KBArea>Support; KB; word97</KBArea>
<KBID>Q10022</KBID>
<KBTitle>OFF97: EPS File Is Not Printed or Is Printed Incorrectly Under Windows NT</KBTitle>
<Description>When you print an Encapsulated PostScript (EPS) file, the file may fail to</Description>
print or may be printed incorrectly." />
<Product>word97</Product>
<KBCreate>April 6, 1984</KBCreate>
<KBModify>April 28, 1999</KBModify>
<EditDate>January 22, 1999</EditDate>
<Question></Question>
<Versions>WINDOWS:97; winnt:4.0</Versions>
<Component></Component>
<Technology></Technology>
<Links></Links>
<Keywords>kbprint offwin offprint</Keywords>
<Platform>WINDOWS winnt</Platform>
<Hardware></Hardware>
<SolutionType>kbfix</SolutionType>
<IssueType>kbbug</IssueType>
<BoilerPlate></BoilerPlate>
<ProducedView></ProducedView>
<QUERYWORDS>EPS</QUERYWORDS>
<QUERYWORDS>filter</QUERYWORDS>
<QUERYWORDS>print</QUERYWORDS>
<QUERYWORDS>garbled</QUERYWORDS>
<QUERYWORDS>does</QUERYWORDS>
<QUERYWORDS>not</QUERYWORDS>
<QUERYWORDS>is</QUERYWORDS>
<QUERYWORDS>printed</QUERYWORDS>

このヒントの提供は:: Anthony Missico, Jr., Independent Consultant, Missico Information Systems, www.missico.com


"大きなファイルを開くときに、WordPadではなくTextPadを開くようにNotePadを操作するか"に対する詳細なヒント

TextPad v4.xのヘルプメニューのよくある質問を読んで、"大きなファイルを開くときに、WordPadではなくTextPadを開くようにNotePadを操作するか"を試したユーザーは、ウインドウズ ライト(.wriの拡張子を持つファイル)を開くときもTextPadが呼ばれ始末に終えないHEXファイルとして開かれることに気がつくと思います。もし「やはりウインドウズ ライトファイルをテキストなのに正しく開きたいときには、下記の方法が使えます。:

エクスプローラーで:

  1. フォルダー C:\Program Files\Accessories\ を開いて WordPad.exeを選択します。コピー + 貼り付けをして "コピー 〜 WordPad.exe" を WordPad1.exeに名前を変更します。
  2. エクスプローラのフォルダーオプションにあるファイルタイプで ライト ドキュメントを選択して編集をクリック、 Open, Print & Printto アクションをWordPad.exe から WordPad1.exe にそれぞれ変更します。
  3. C:\Windows\Start Menu\Accessories\WordPad.exe のリンクのプロパティーを編集して "リンク先" をWordPad.exe から WordPad1.exeへ変更。.

これは Windows と TextPad v4.xのどの組み合わせでも大丈夫です。

このヒントの提供は:: Dave Rudd, AMIEE


マイクロソフト インテリマウス エクスプローラーの親指ボタンを使用するには:

大小の親指ボタンは、Alt+右矢印とAlt+左矢印と同じメッセージを生成する。そこで、TextPadのページアップダウンを割り当てできます。:

  1. 設定メニューの環境設定を選択
  2. キーボードショートカットを選択。
  3. 分類リストから "Cursor"を選択。
  4. コマンドから "PageUp"選択。
  5. ショートカットボックスから、Altキーを押しながら右矢印を入力。
  6. 割り当てをクリック。
  7. コマンドから "PageDown"を選択。
  8. ショートカットボックスから、Altキーを押しながら左矢印を入力。
  9. 割り当てをクリック。
  10. OKをクリック。

環境変数を設定したJava Applications の実行の仕方。:

serveletとオラクルデータベースを使用したいと仮定します、TextPadでjavaアプリケーションを作成しようとするとき、 コマンドラインが長すぎてどうにもならなくなるでしょう。そこで環境変数を使用してjarファイルやclasspathの設定を保存することが考えられます。 TextPadの普通のjavacセットアップではこれらの環境変数を使用することはできませんので下記のように指定する必要があります。:

あなたの c:\autoexec.batで下のような設定があったとします。

		SET PATH=%PATH%;c:\oracle\ora81\bin;c:\java\jdk12~1.2\bin;c:\java\classes
		SET CLASSPATH=c:\java\classes
		SET JARFILES=c:\java\classes\servlet.jar;c:\java\classes\oracle.jar
		
  1. TextPadの設定メニューの環境設定を選択。
  2. ツールマネージャーを選択
  3. 追加ボタンをクリックして "Dos コマンド"を選択
  4. ボックスに下記の行を入力:
    javac -classpath %JARFILES%;%CLASSPATH% -d c:\java\classes $File
    		(Note: -d は javac に生成したいclassファイルを指定します。)
  5. Okをクリック。

この設定に下記の情報を追加します。:

コマンド:COMMAND.COM
引数:javac -classpath %JARFILES%;%CLASSPATH% -d c:\java\classes $File
開始フォルダー:$FileDir
出力の取り込み :チェック
終了時の音を鳴らす:チェック
正規表現:^\(\(\(\\\\[^\]+\\[^\]+\)\|\([A-Za-z]:\)\)[^:]+\):\([0-9]+\):
ハイパージャンプ先の割り当て:ファイル=1, 行=4

このヒントの提供は:: Garth Fielding


TextPad と LaTeX

LaTexを編集するときの鍵は、編集-コンパイル-表示-編集の繰り返しをできる限り短くすることです。

そのために、関係する全てのツール TextPad ( TeX コンパイラーとDVIビューワーの起動)を正しく設定する必要があります。 TeX コンパイラー ("e"をタイプしただけで直接えらーレポートの場所へ飛べるように) と DVI ビューワー (ダブルクリックしただけでTextPadの文章へジャンプできるように)。

ここでは 私の持つ TeX ディストリビューションの MiKTeX を取り上げました。 他のディストリビューターでも設定の場所を見つければ同様にできるでしょう。

LaTeXと連携

TextPadはLaTex専用にデザインされているわけではないので、設定に留意が必要です。

最初に貴方がどのようにLaTexを使用するか決定する必要があります。単一"projects"のファイルでまたは、メインファイルから呼び出す複数のファイルで作業するかです。

ここでは、複数のファイルを含むメインファイルで作業する方法を述べます。もしそうでなければそれなりの変更が必要です。

なぜなら現在のファイル名かワークスペース名のいずれかしか与えることができないからです。もし、現在のファイル名を与えるのであれば、メインファイルからTexコンパイラーを起動するようにする必要があります。複数のファイルを開いているときはこれが調子が悪いのです。

方法としてはLaTexのプロジェクトそれぞれにTextPadのワークスペースをLaTexのメインファイルと同じbasenameで作成することです。それによって、どのファイルを編集していても、メインファイルからコンパイラーを起動できます。他の方法では、メインファイルをいつも同じ名前(main.texのように)にすることです。

As I have the german TextPad the translations of edit-field labels are more of a general guideline :-)

TextPad

"複数のTextPadを実行"をオフにしてください。!そうしないと DVIビューワーのジャンプで新しいTextPadのインスタンスが起動してしまいます。しかもそのインスタンスではワークスペースが存在しないので正しく働きません。

ツールを2つ作成:

DOS コマンド TeX コンパイラー:

		引数:          texify --src $WspBaseName.tex
		起動ディレクトリー:  $WspDir
		

全てのファイルを保存にしておくとよいでしょう。出力は取り込まないでください。終了後ファイルを閉じてもかまいません。

--src は、後方検索を可能にします。

単一ファイルでの LaTeX プロジェクトはワークスペース名使用せずをファイル名に置き換えます ( $FileName と $FileDir を $WspBaseName.tex と $WspDirの代わりに)

DVI ビューワーの登録:

		プログラム:    yap.exe
		引数:  -1 -s $Line$FileName $WspBaseName.dvi
		開始ディレクトリー: $WspDir
		

yapの代わりにお好みのDVIビューワーを入れてください

-1 は、開いているインスタンスを使用するよう指定します
-s は、前方参照を指定します。これは、メインファイルでなくても機能します。yapは、現在のファイルのカーソル位置の場所を開きます。

単一ファイルでの LaTeX プロジェクトでは $BaseName と $FileDir を $WspBaseName と $WspDirの代わりに使います。

DVI-ビューワー (yap)

"View", "Options...", "Inverse Search", "Command line" の下に下記を入れます

		textpad "%f"(%l)
		

これで、ダブルクリックしたときにTextPadを起動できます。

TeX

TeX でエラーを生じたときに、スクリーンの表示上に"e"を押して編集することができます。エディターは、MiKTeXのINIファイル又は、他のディストリビューターでも同様に設定があるでしょう、の中で指定できます。

新しいファイル(mymiktex.ini) を作成

		[TeX]
		Editor=textpad "%f"(%l)
		

次に呼び出します。

		initexmf --personal=mymiktex.ini
		

これでnotepadの代わりにTextPadが起動されます。

ウムラウトとアクセント

inputenc-packageを使用すれば、LaTexのプリアンブル部でウムラウトやアクセントをTeX表記に代えるためにマクロを使用する必要はありません。

		usepackage[ansinew]{inputenc}
		

入力できる全てのキャラクターを使用できるはずです。ドイツ語のみでしか試していませんが。

これでおしまい:

  1. 新しいTeX-fileを作成 "FirstTest.tex".
  2. 新しいワークスペースを保存。 "FirstTest.tws" の名前で作成されますので入れなおす必要はありません。
  3. "FirstTest.tex"を編集。
  4. DVI ファイルを作成します。
  5. エラーがあれば"e"をタイプして修正します。
  6. 結果を見るのにyapツールを使います。yapはカーソルのある部分にジャンプします。
  7. yapのどこかをダブルクリックして、TextPadの関連するパラグラフへジャンプします。

このヒントの提供は:: Jens Hollmann. 12 October 2001.